Carta by Focus V

Ferrusbuelker

Well-Known Member
I hate to repeat an earlier post but has anyone else been having difficulty receiving a response from focus. Ive been trying since mid July to assure that I received a magna carts or holy white for being a memeber of the beta team? I’ve sent multiple emails, dms on here and IG and after posting publicly on here I finally got a response saying “oh if you didn’t get yours let us know and we will ship immediately. Then no response after two more follow ups.

I dislike writing this and told FV that I didn’t want to resort to this but it's the only way I've elicited a response from them recently. I’ve tried communicate repeatedly with focus for getting engraving and then when I didn’t get an answer I sent reminders to make sure I got a holy white. I was told on IG that they were social media and marketing and didn’t handle emails. Although my dm was asking about giving my serial number to make sure I received a holy white. So it seemed like an odd response. To be fair until mid July Focus had been very responsive and supportive of any issue I had.

Another reason I’m writing is because the only other time I’ve been ignored by a company in this industry was with the hex nails girls but I never said anything I knew much earlier there were problems and kept quiet and that didn’t turn out so well for people. Not saying this is the same but

I believe this is also about accountability. I paid $200 as beta member, I gave feedback to Focus both publicly and privately and I haven’t heard anyone else on the beta team not receiving a unit. My hope is this constructive feedback from someone who is concerned about the lack of response.
 
Last edited:

Fkn0wned

Well-Known Member
@Ferrusbuelker
Oh I'm on the same boat as you my friend.

I was before the deadline sending my engraving only to later be told I wasn't on the engravings list, then heard about everyone getting holy whites instead of the all black so I DM'ed IG about it which took awhile but they finally saw I was indeed a beta users and said I would be sent an all black since I really didn't want the holy white.

So they set an order up for me on August 2nd which still hasn't been shipped out, I've been waiting a month.

I did get a DM asking for my account email from @FocusV when he came to the forum the other day which I gave and then asked further questions but I haven't received another reply yet again.

So I DM'ed IG again and said what's with my order it's been processing for an entire month and this was the response I got.

"Wow I just checked your order, you’re right. I apologize we had a problem with our old fulfillment center. They were falling short! Can’t believe they didn’t send that out‍♂ we switched warehouses and are supposed to be getting all their stock in this week or next. I hope we can still get you an all black Magna Kit. I truly apologize, this is one of the reasons we had to move warehouses."

So I'm not sure what is going on, the shop I work at said all the whole sellers we receive from didn't have any stock of any of their products so who knows what's going on.
 

Ferrusbuelker

Well-Known Member
@Fkn0wned sounds like you are getting a bit of the old run around as well. As frustrating as that is I appreciate you letting me know that my concerns are valid. My hope is your issue is resolved soon.

I do appreciate Focus having a beta program and the extras that have been promised and sent out. I have some thoughts and also received some messages about what is going on but I’m not looking at their balance sheet or assuming I understand all the circumstances/issues that could come up when running a business in this industry. I’m going to wait to hear from @FocusV to clarify before making any assumptions or disseminating any false information.

In the past, I was use to chatting with Randall and his responses were always within a day, positive and helpful. As business picks up I’m sure there are some growing pains as been referenced before and communication can break down. Hopefully, this is a bump in the road as I would like to see Focus succeed.

All niceties aside I still want my black magna or HW.:shrug:
 

mrbonsai420

Accessory Maker
Accessory Maker
just rebuilt my atty, up and running again :)

I have the app, but is Sesh mode working for you guys or just normal mode? They may have disabled it, I am just curious?
 

mc

Well-Known Member
Little help please......just switched atomizers from concentrate to flower tried the flower atomizer then decided to put concentrate atomizer back on when I did it started overheating like crazy....thought it needed a rebuild......still overheating....thought it needed a new atomizer all together.....still overheating....this is a black magna carta. I got a v2 carta also and it works just fine.....anyone know what's up.......
My beta unit did this. I think you are stuck in flower mode, might want to get the app loaded and try to set the temp manually. But this caused two of my atomizers to start on fire.
 

Azn2101

Well-Known Member
I think that's a bad atty, take it off and clean it and the base side. Then try it again and let us know.
Sweet man, Thank you. It does make the sotuation that much weirder though.

The person I'm helping said they bought the Carta and the original base & atty flashed white 8 times. He RMA'ed the atty and got an Everlast back and it flashed 8 white so then they RMA'ed the base and he even tried a repair kit on the v2 before RMA'ing it

I was thinking maybe the original base he might've bought from a shop and it being one from the v1-v2 base switch time period but I'm sure he'll get it up & running

Any ideas guys? He's reset both units by reverse polarization.
 

Azn2101

Well-Known Member
He's saying that the batteries are fully charged from the light showing green when plugged in.

I'm sure he'll get it worked out though thank you for the help guys.

So just to check, has it been clearly stated if the FocusV SiC inserts are "American" or "Chinese"?
 

freddiegibbs

Well-Known Member
He's saying that the batteries are fully charged from the light showing green when plugged in.

I'm sure he'll get it worked out though thank you for the help guys.

So just to check, has it been clearly stated if the FocusV SiC inserts are "American" or "Chinese"?
He's probably not using the stock charger. 8 white lights is definitely the batteries though, which makes it kinda crazy that he did all those RMA's.
 

bannakaffalatta

Well-Known Member
Anyone know what is up with Focus V's Video/Phone Consulation? They told me for my warranty I needed to sign up for it, but never got a phone call or anything from them.

I signed up for the 5:00-5:30 nothing, 6:15 - 6:45 nothing, 6:45 to 7:15 nothing. I just signed up for the 7:15 which is in 8 minutes, though I am doubting that they call. Also I tried the live chat, but no one is answering on that.

edit: 7:20 and no call. I kind of feel like an idiot siting here waiting since 5pm trying to deal with this warranty.
 
Last edited:

jimsmith90210

Who Is Nate?
Reports on reddit about the new FocusV SiC bucket getting very hot and possibly melting the top lid of the atomizer housing.

Anyone on here have one yet?

Any beta users get a shipping notification for their Everlast atomizer and SiC bucket?
 

Ph0ur20

New Member
Reports on reddit about the new FocusV SiC bucket getting very hot and possibly melting the top lid of the atomizer housing.

Anyone on here have one yet?

Any beta users get a shipping notification for their Everlast atomizer and SiC bucket?
I’m not a beta user but I got my sic insert and I am not using it anymore because the atomizer gets extremely hot. It was not working on the lowest setting I was getting no clouds. They also sent it to me in a bubble cap box they don’t even have sic insert boxes it’s so lazy.
 

jimsmith90210

Who Is Nate?
They didn’t like those posts on Reddit so they deleted them saying there is a smear campaign against them.
Oh my

"....we want to reassure that any and all comments are welcome. BUT, with that being said anything deemed out of place, trolling, spam, hate speech, or harassment will be removed. ...."

This makes me feel really weird.
 

Ph0ur20

New Member
I’m not a beta user but I got my sic insert and I am not using it anymore because the atomizer gets extremely hot. It was not working on the lowest setting I was getting no clouds. They also sent it to me in a bubble cap box they don’t even have sic insert boxes it’s so lazy.
I’m not trying to smear them in anyway shape or form I actually like my Carter and I own two of them and the Everlast is working great. Any warranty issues I had got rectified in a timely manner. I’m just kind of sour on how the sic insert works and the way I got it delivered.
 

freddiegibbs

Well-Known Member
I’m not trying to smear them in anyway shape or form I actually like my Carter and I own two of them and the Everlast is working great. Any warranty issues I had got rectified in a timely manner. I’m just kind of sour on how the sic insert works and the way I got it delivered.
Wait, you're actually mad that they sent it to you in bubble cap box? Why?

I also haven't used the sic insert in a couple months since Randall had his prototype, but from what I remember, level 1 is too low. You have to use it at temps similar to the quartz bucket.
 

Ph0ur20

New Member
Wait, you're actually mad that they sent it to you in bubble cap box? Why?

I also haven't used the sic insert in a couple months since Randall had his prototype, but from what I remember, level 1 is too low. You have to use it at temps similar to the quartz bucket.
I am not mad about it coming in that box. I do perceive it as something being rushed out to customers since it’s not put in the proper container like everything else was. I appreciate the tip on the sic bucket since I have never used a insert like that.
 
Top Bottom