Pen Imag Plus

paytonpenn

Level 30 Nature/Healer
thanks @paytonpenn!!! :) so, what is your over opinion on its performance?? that money in my wallet is calling me
Consistent and good performance, the 3 temperature levels are spaced at good points for me.

I've done most of my testing with ABV so far but from how well its able to still extract this abv tells me it will be phenomenal with something fresh.
 
Last edited:

mmenzie

My friends call me "Menz"
ok, i think i am going to take the chance... like i said... at worst i spent another $50 on a busted product (i bought 2 "dry herb" pens that have coils and are clearly not for dry herb but make excellent oil vapes). thanks again
 
mmenzie,

TNT_error

Well-Known Member
This "pen" works very well. It's like a Flowermate in taste and efficiency, but better. The imag+ takes a smaller load, and it last forever! (I've done only max halfway packed, and it took almost an hour to finish). This thing is pure conduction with no coils. You would love the ease of use and feel of the imag+ @mmenzie
 

Shit Snacks

Milaana. Lana. LANA. LANAAAAA! (TM/FW7/OAB/CC-H&A)
Yeah, I got a quote from him too before I went with CiCy bc she matched his price for me.

It works while charging, but it will damage the battery (unless that was the mystery change they made to the chip set?!)
 
Shit Snacks,

FUnhouse

Well-Known Member
Yeah, I got a quote from him too before I went with CiCy bc she matched his price for me.

It works while charging, but it will damage the battery (unless that was the mystery change they made to the chip set?!)
I wrote her (Cicy) to ask about that already . I should hear back by Monday .
 

Puffers

Micro-Climate Mastermind
The manufacturer told me directly DO NOT use while charging. I can contact them again and ask if any changes were made but I really dont think so.

This has been a really solid unit so far for me and puts out copious vapor for the size. It does get hot with multiple cycles and should have some cool down time. The mouthpiece unless it's already been revised will slowly clog up and make for a tight draw. The size as Payton has noted is a bit larger then a mechanical ecig mod but not much.

I think there is a fair amount of convection going on in this unit, when I heat it up and leave the lid off it doesn't spew vapor in the volumes that you can draw through the unit.
 

mmenzie

My friends call me "Menz"
Well it seems that my posting the deal I got, got the seller in trouble. I apologize to anyone that this also may have caused issues for as well. I have reported my post and asked to have it deleted. as it turns out I may have also caused me not to get one as well as the seller told me he is no longer allowed to sell to me. I hope I get my money back or this will be a costly mistake on my part :(
 

paytonpenn

Level 30 Nature/Healer
Had an odd incident, going with 3 back to back sessions on red I attempted to dump out the bowl and the plastic end of the mouthpiece came off with the screen still stuck in the vape.

It was gluey looking, I pressed it back in like normal and was able to remove the whole mouthpiece. Tried recreating the incident with no avail. Even tried forcing it out but just ended up denting the screen.

I realized I really wanted to clean it after I closed it back up.

Does the timeout reset when I change temps, still unsure but I feel it does. Will actually test that soon.
 

Hoops

Well-Known Member
Had an odd incident, going with 3 back to back sessions on red I attempted to dump out the bowl and the plastic end of the mouthpiece came off with the screen still stuck in the vape.

I had the same problem over the weekend...but my screen won't go back into the MP. I'm able to use one of the short stems from the HI as a temp MP with screen...but as of this morning I've reached out to W9 for direction on where I'm supposed to go with this now.
 
Hoops,

Kaptan

Well-Known Member
Well after about 10 days of use, my imag plus will no longer turn on. When I plug the charger in, the charge light is green. It was a great portable vape, but now I'm doubting its long term reliability. I have sent a couple of emails to Shirley and no replies. I guess it's time to file a Paypal dispute?
 

THC SCIENTIFIC

To Boldly Go Where No One Has Gone Before
Manufacturer
Well after about 10 days of use, my imag plus will no longer turn on. When I plug the charger in, the charge light is green. It was a great portable vape, but now I'm doubting its long term reliability. I have sent a couple of emails to Shirley and no replies. I guess it's time to file a Paypal dispute?

We might be able to help you.

Let me see if we can get you a free replacement.
 

THC SCIENTIFIC

To Boldly Go Where No One Has Gone Before
Manufacturer
That would be excellent if you could help and very much appreciated:rockon:

Please ship the unit to us and put in the notes that it needs to come directly to Gary, once we receive it i will contact the manufacturer and see what we can do and when we can get a unit to you by.

Please understand there will be shipping charges and customs fees that will apply when we ship the unit to you since we have to pay customs fees for our deliveries.
 
Last edited:

CidKudi

Man on the Moon
The sudden defects some of you are facing worries me. After having the unit for a few weeks i've found a way to clear the screen. Turn the temp up to red and put the mouthpiece on the top. The high heat warms up the resin stuck in the tiny screen and makes it easier for it to come out. After the three minute timer take off the mouthpiece and blow into it. Now look at the screen and there will be a lot more resin on the surface. Take a tissue/paper towel and wipe it away. I then usually look through the mouthpiece against my ceiling light so I can see if the holes need to be cleared more. Hope this helps some people.
 

StormyPinkness

Rhymenocerous ʕ•ᴥ•ʔ
It's worrying me too. Still waiting for the new chip version to ship since the 26th. I'm thinking about cancelling.
 
StormyPinkness,
  • Like
Reactions: mrweed

TNT_error

Well-Known Member
Dammit! Just had the problem @paytonpenn and @Hoops mentioned. My MP just came off while the screen was still attached, but in this case both won't come back together. Bummed...
 
TNT_error,

Yoosh

Well-Known Member
I'm still having no issues with my original Imag/Xmax. Used multiple times every day. :shrug:

Edit: Perhaps it's the high heat intensity of being on Red for extended sessions? Mine has no temp control so it just steps up the temp from 190-220.
 
Last edited:
Yoosh,
  • Like
Reactions: mrweed

Yoosh

Well-Known Member
Have you done 3 sessions back to back on red? That's how mine shitted out

I've done 5 back to back sessions before but mines the original model without the temp options. I think the high heat of Red (for multiple sessions) is probably what's causing the issue.
 
Top Bottom