NFC Alpine 2020 - Induction Heater

Rickj25

New Member
Well mine had the magnet issue, the lid was loose, but it worked for about 10 minutes. Then I saw what looked to be a flash, like an electrical short. And now it doesn’t work. I’m thinking one of the solder joints wasn’t solid. It’s a shame because I like the size and look of it. I just wish they would have made an ounce of effort in QC. Also there was a QC card that made me laugh.
 

junny89

Well-Known Member
Finally found the alpine thread!
sadly like most of you, I got a shipping email via DHL (UK) still hasn’t moved. I got worried and called dhl, they haven’t even received the parcel at all. Customer service hardly replies and even then it’s, they missed your parcel it was collected today. Nearly a month now and still nothing. Last email was last week saying they would be collected and shipped the same day. Quality control took longer than expected and all kids were reseated.
Not sure what’s going on and the tracking has still not budged....
 

thunderstealer1337

Active Member
Finally found the alpine thread!
sadly like most of you, I got a shipping email via DHL (UK) still hasn’t moved. I got worried and called dhl, they haven’t even received the parcel at all. Customer service hardly replies and even then it’s, they missed your parcel it was collected today. Nearly a month now and still nothing. Last email was last week saying they would be collected and shipped the same day. Quality control took longer than expected and all kids were reseated.
Not sure what’s going on and the tracking has still not budged....
Don't worry he will keep lying to you like he did to me, for like 1 month of we are qc, we are laser engraving, we are packing, all orders now shipped etc.... then will tell you oh yea, we may have printed the labels but they never got printed

like this

" The Alternative theory (the one we hope is the case) is that a handful of you may have had a label generated but it just never left queue for printing. ( although we would like to think this as a possibility the likely hood is slim.) "

I got a response from USPS that my 7/2 was never shipped, and sender did not ship it, end of story, yet the maker keeps spouting lies that usps lost it, and they are sending the requests to get packages back.

He also called me on 7/13 stating my engraving wont work, clear evidence this was literally the 1st time they tried to engrave it - and I preordered 1st week of May.

So shady of a business practice, hope he fails miserably, nobody deserves to get lied to and should be able to get pertinent information about their order on their personal emails that placed the order, and not have to rely on lies on public forums.
 
thunderstealer1337,
  • Like
Reactions: Nomad #111

vtac

vapor junkie
Staff member
Please don't make us start a shipping thread for this one guys....

Just sayin'. :rolleyes:

:peace:
And please remember that we don't want or allow threads to be used as soapboxes for individual customer service issues. Generally speaking the rule is that you get one post to state your CS issue and the company gets one post to respond, if applicable. Thank you. :peace:
 
vtac,
  • Like
Reactions: LabPong

fatbiker

Well-Known Member
For those of you who have had issues were you able to initiate an exchange or refund?
 
fatbiker,

acstorfer

Take My Money Dammit!
For those of you who have had issues were you able to initiate an exchange or refund?
I contacted them about my loose top and asked them if they can send me a top with a proper magnet seeing how I had to glue it on anyway. They couldn’t send me a new top but did offer to have me send mine back for repair. I just glued the top on.
 
acstorfer,

thunderstealer1337

Active Member
I have (as well as others who contacted me privately on Reddit). Mine sparked loudly and brightly internally when I stuck in my vape the very first time. Smoke came out and smelled up my apartment for a couple days, even though I only turned it on for an instant. If that had been the only issue, I would have gotten a replacement (because sometimes shit happens). But then it was clear the CS department didn't care (had no curiosity about what happened, and seemed to make a point of waiting 24 hours between each response). I started seeing other people with issues, read up on the questionable charging system, as well as how you have to adjust the coils to get the heater to work right. Clearly this system was not designed by an expert, and the factory was not given correct specs (see the magnet issue). Clearly there was not even the basic QC done on these (just press the button and see if it shorts out!).

And to top it all off, they tell me I can't get a refund because I opened the package?! Randall states that the "satisfaction guarantee" on the Toggen website is "alternative information"?! Forget it. These guys are hoping to unload their garbage as fast as possible.
Lol you should see the almost daily reddit posts about the units sparking/no charging/smoldering and smoking lol. Pretty glad I returned and never have to worry it will burn down my house
 
thunderstealer1337,
  • Like
Reactions: RustyOldNail

thunderstealer1337

Active Member
Refund is finally done, so it looks like about 5 business days tat after they receive the package.

I did have to email them on like the 4th day asking about it since it was delivered already, so who knows if I did not email them.

The funny thing is they told ups the package is lost 4 days after tracking says it was returned to LA, cuz tracking is saying this now:
We've begun an investigation to locate the package.
 
thunderstealer1337,
Top Bottom